Usar Função Índice() Corresp() agrupadas Excel

Dica super rápida!

As vezes algumas pessoas têm dificuldades em usar o agrupamento das funções =ÍNDICE() e =CORRESP(), mas basta entender como cada uma delas funciona que fica fácil, fácil.

Primeiro devemos entender a função =ÍNDICE().

Essa função busca em qualquer coluna, em uma base pré-estabelecida pelo usuário, um valor com base em um número de linha.

Por exemplo, se você tem o exemplo abaixo:



e quer que a função =índice() retorne o departamento do "Henry", bastava usar a seguinte função: "=ÍNDICE(A2:C5;1;2)" (sem as aspas).

Essa função usa como base de dados os valores presentes nas células de A2 até C5, busca na linha 1, coluna 2.

Mas e se você não conhecer previamente o número da linha? Se o valor dessa linha alterar com base em um botão, por exemplo?

Aí é que entra a função =CORRESP().

Essa função retorna o número da linha com base em algum critério estabelecido pelo usuário.

Por exemplo, a função "=CORRESP(A2;A2:A5;0)" retornaria o valor 1. Por quê?

Simples, o primeiro parâmetro dessa função está dizendo que o valor procurado é A2, ou seja, Henry. Na base de A2 até A5 e a correspondência é 0, isto é, exata.

Juntando as duas fórmulas, teríamos: "=ÍNDICE(A2:C5;CORRESP(A2;A2:A5;0);2)"

Viu a simplicidade? No lugar de colocar o valor de linha 1 na função índice, colocamos a função corresp, que vai buscar esse valor e botar na índice. Se você mudar o nome do Henry para qualquer outro lugar na coluna A, automaticamente a função corresp retornará a linha correspondente!

Simples e fácil!

Qualquer dúvida, comente que tentamos ajudar!


Nome do Autor

Sobre o autor

Flávio Santos é o editor-chefe do Tecla Ti. Vice campeão de todas as Américas em Tecnologia da Informação pela Worldskills Americas. Especialista Microsoft Office, programador VBA, C, JAVA, PHP e desenvolvedor de aplicações. Leia Mais sobre o autor >>>

5 comentários:

Olá! Tudo bem? Gostei das informações que postou e quero agradecer pq me foram muito úteis. Se for possível me responder, visto que não entendo muito de excel, ficaria muitísimo grata. Existe alguma função ou fórmula que consiga PROCURAR um determinado (DADO) em uma coluna e consequentemente, copiar todos os dados da linha onde a célula tem esse DADO (texto)? Como faço?

Obrigada!

Olá! Voce sabe como posso usar o conteúdo de uma célula como "Nome de Planilha!" numa fórmula. Por exemplo, na prática podemos usar a fórmula "=Planilha1!A2" para buscar o conteúdo da celula A2 na Planilha1, mas eu quero que o nome da Planilha1 seja dinâmico, ou seja, o conteúdo de uma outra celula. Como faço?
Grato.

Muito obrigada pelas informações, foram múuuito úteis.
Pri

Boa tarde Flavio,
Preciso de finalizar um cronograma de atividades com base nos dados de outra planilha com o campos abaixo:

Nome, DataInicio, DataFim, Atividade
João 01-01-12 05-01-12 primeira
Pedro 03-01-12 04-01-12 primeira
João 07-02-12 10-02-12 segunda

Não estou conseguindo identificar uma formúla que permita 3 critérios:
Nome;
DataInicio MAIOR ou igual a data especificada;
DataFim MENOR ou igual a data especificada.

Cronograma será semanal, conforme abaixo:

Nome | 01a05 | 08a12 | 15a19
João | 01a05 primeira | |
Pedro | 03a04 primeira | |

Você consegue me ajudar?

Obrigado
Eduardo Martins

GOSTARIA DE SABER SOBRE A FUNÇAO FILA, QUAL FUNÇÃO REPRESENTA ESTA NO EXCEL 2010

Postar um comentário